🔗 Security Engineering Blog

Citrix Patches Critical NetScaler Console Vulnerability

2024-07-10 13:43:24 UTC

Citrix has released patches to fix critical and high-severity security vulnerabilities in its NetScaler product line. The updates address a critical vulnerability in the NetScaler Console. The company has urged users to install the patches to protect their systems. News of the Citrix patches was first reported by SecurityWeek.

Read More